Home                Company                Products                Gallery                Store                Links
 
Products
Aurora
Aurora Water
Aurora Sky
Plant Mechanic
Verdant
ModelShop
WorldBuilder
Export 184
Quick Links
News
Press
Discussion Groups
Register Online
Download
Services
Support


Digital Element plug-ins compatibility list

The plug-ins are compatible with Adobe Photoshop/AfterEffects running on:
  • Windows XP, Windows Vista or Windows 7, 32-bit and 64-bit versions.
  • Mac OS X 10.4 (Tiger), 10.5 (Leopard) or 10.6 (Snow Leopard), 32-bit and 64-bit mode .
Plug-ins for Adobe Photoshop Aurora Verdant Modelshop
Adobe Photoshop v.6 Yes Yes Yes
Adobe Photoshop v.7 Yes Yes Yes
Adobe Photoshop CS (v.8) Yes Yes Yes
Adobe Photoshop CS2 (v.9) Yes Yes Yes
Adobe Photoshop CS3 (v.10) Yes Yes Yes
Adobe Photoshop CS4 (v.11) 32-bit version Yes Yes Yes
Adobe Photoshop CS4 (v.11) 64-bit for MS Windows Yes Yes Yes
Plug-ins for Adobe After Effects and
Apple Final Cut Pro for Apple Mac
Aurora Sky Aurora Water
Adobe After Effects v.4.1 Yes Yes
Adobe After Effects v.5.x Yes Yes
Adobe After Effects v.6.x Yes Yes
Adobe After Effects v.7.x Yes Yes
Adobe After Effects CS3 (v.8.x) Yes Yes
Apple Final Cut Pro v.4.x Yes No
Apple Final Cut Pro v.5.0.x Yes No
Apple Final Cut Pro v.5.1.x Yes Yes
Apple Final Cut Pro v.6.0 Yes Yes